LIBRARY HOURS

7:30am - 11:00pm

facebook iconTwitter icon

Browser FAQ



Some indexes/databases and the Library Catalog require minimum Internet Browser versions to function properly. If you are having problems displaying screens correctly, printing articles, or linking to resources within indexes, you may be using an older version of an Internet browser that is no longer supported by the index/database or catalog.

To determine the version of the Internet browser you are using:

  • In Internet Explorer.. .
    Click on "Help" in bar at the top of the screen,
    Then click on "About Internet Explorer"
    The version you are currently using should be displayed in the pop-up box.

  • In Firefox...
    Click on "Help" in bar at the top of the screen,
    Then click on "About Mozilla Firefox"
    The version you are currently using should be displayed in the pop-up box.


To upgrade Internet Explorer or Firefox:

Before downloading a newer version, please read the information on the Internet Explorer and Firefox sites about the version. There are minimum computer hardware and software requirements for the current browsers.


If you are using the browser version that is recommended and you still encounter problems, the index/database or catalog may also require certain settings or configurations in your browser. More information about browser configurations